<!DOCTYPE html>
<html class="no-js mh-two-sb" lang="en-US"
prefix="og: https://ogp.me/ns#" >
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://www.70westsentinel.com/scoop/xmlrpc.php"/>
<title>St. Charles County Food Inspection Scores: Chillax, Chilli&#039;s, Texas Roadhouse, McGurk&#039;s, and more | 70 West Sentinel</title>
<meta name="description" content="The St. Charles County Department of Public Health monitors more than 1,300 food service providers in St. Charles County. (The City of St. Peters conducts its"/>
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.70westsentinel.com/#organization","url":"https://www.70westsentinel.com/","name":"70westsentinel.com","sameAs":["https://www.facebook.com/pages/70-West-Sentinel/1385421705081587?ref=hl","https://twitter.com/70WestSentinel","https://plus.google.com/b/117040150402076780761/117040150402076780761/posts?pageId=117040150402076780761"],"logo":{"@type":"ImageObject","@id":"https://www.70westsentinel.com/#logo","url":"https://www.70westsentinel.com/scoop/wp-content/uploads/2016/12/cropped-70west_site-logo.png","caption":""},"image":{"@id":"https://www.70westsentinel.com/#logo"}},{"@type":"WebSite","@id":"https://www.70westsentinel.com/#website","url":"https://www.70westsentinel.com/","name":"70 West Sentinel","publisher":{"@id":"https://www.70westsentinel.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.70westsentinel.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#webpage","url":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/","inLanguage":"en-US","name":"St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more","isPartOf":{"@id":"https://www.70westsentinel.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#primaryimage","url":"https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg","width":400,"height":304,"caption":"File photo"},"primaryImageOfPage":{"@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#primaryimage"},"datePublished":"2020-03-27T22:16:29-05:00","dateModified":"2020-03-27T22:16:29-05:00"},{"@type":"Article","@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#article","isPartOf":{"@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#webpage"},"author":{"@id":"https://www.70westsentinel.com/author/tam/#author"},"headline":"St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more","datePublished":"2020-03-27T22:16:29-05:00","dateModified":"2020-03-27T22:16:29-05:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#webpage"},"publisher":{"@id":"https://www.70westsentinel.com/#organization"},"articleSection":"Business, Government, Health, St. Charles County, Food Safety, Restaurant Inspections, tam, tam","image":{"@type":"ImageObject","@id":"https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#primaryimage","url":"https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg","width":400,"height":304,"caption":"File photo"}},{"@type":"Person","@id":"https://www.70westsentinel.com/author/tam/#author","name":"Tamara Duncan","sameAs":[]}]}</script>
<link rel="canonical" href="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="St. Charles County Food Inspection Scores: Chillax, Chilli&#039;s, Texas Roadhouse, McGurk&#039;s, and more | 70 West Sentinel"/>
<meta property="og:description" content="The St. Charles County Department of Public Health monitors more than 1,300 food service providers in St. Charles County. (The City of St. Peters conducts its own inspections.) Routine inspections are"/>
<meta property="og:url" content="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/"/>
<meta property="og:site_name" content="70 West Sentinel"/>
<meta property="og:image" content="https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg"/>
<meta property="og:image:width" content="1200"/>
<meta property="og:image:height" content="630"/>
<meta property="fb:admins" content="1385421705081587"/>
<meta property="fb:app_id" content="305858336478533"/>
<meta property="article:tag" content="food safety"/>
<meta property="article:tag" content="restaurant inspections"/>
<meta property="article:tag" content="business"/>
<meta property="article:tag" content="government"/>
<meta property="article:tag" content="health"/>
<meta property="article:tag" content="st. charles county"/>
<meta property="article:published_time" content="2020-03-27T22:16:29Z"/>
<meta property="article:modified_time" content="2020-03-27T22:16:29Z"/>
<meta property="article:publisher" content="https://www.facebook.com/pages/70-West-Sentinel/1385421705081587?ref=hl"/>
<meta property="og:image:secure_url" content="https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@70WestSentinel"/>
<meta name="twitter:domain" content="70westsentinel.com"/>
<meta name="twitter:title" content="St. Charles County Food Inspection Scores: Chillax, Chilli&#039;s, Tex"/>
<meta name="twitter:description" content="The St. Charles County Department of Public Health monitors more than 1,300 food service providers in St. Charles County. (The City of St. Peters conducts its own inspections.) Routine inspections are"/>
<meta name="twitter:image" content="https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="70 West Sentinel &raquo; Feed" href="https://www.70westsentinel.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="70 West Sentinel &raquo; Comments Feed" href="https://www.70westsentinel.com/comments/feed/"/>
<link rel="alternate" type="text/calendar" title="70 West Sentinel &raquo; iCal Feed" href="https://www.70westsentinel.com/events/?ical=1"/>
<link rel="alternate" type="application/rss+xml" title="70 West Sentinel &raquo; St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more Comments Feed" href="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/feed/"/>
<link rel="stylesheet" type="text/css" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/eiaax0iz/1g97.css" media="all"/>
<link rel='https://api.w.org/' href='https://www.70westsentinel.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.70westsentinel.com/scoop/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.70westsentinel.com/scoop/wp-includes/wlwmanifest.xml"/> 
<link rel='prev' title='St. Charles County WIC program services still available; staff working remotely due to COVID-19' href='https://www.70westsentinel.com/st-charles-county-wic-program-services-still-available-staff-working-remotely-due-to-covid-19/'/>
<link rel='shortlink' href='https://www.70westsentinel.com/?p=148964'/>
<link rel="alternate" type="application/json+oembed" href="https://www.70westsentinel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.70westsentinel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F&#038;format=xml"/>
<style media="screen">div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited, div.printfriendly a:focus{text-decoration:none;border:none;-webkit-box-shadow:none!important;box-shadow:none!important;}</style>
<style media="screen">div.printfriendly{margin:24px 0px 16px 0px;}
div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited{font-size:14px;color:#3AAA11;}</style>
<link rel="stylesheet" type="text/css" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/12b9qvok/1g97.css" media="screen"/>
<style media="print">.printfriendly{display:none;}</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.70westsentinel.com"><link rel="https://theeventscalendar.com/" href="https://www.70westsentinel.com/wp-json/tribe/events/v1/"/><style>.fas.fa-user:before{content:'\f007';}
.fas.fa-user{margin-right:5px;}
.mh-meta.entry-meta-author{margin-top:0.375rem;padding:0 10px 5px;border-bottom:1px dotted #ebebeb;}
.error404 .mh-content,
.mh-two-sb .error404 .mh-main{width:100%;}
.mh-two-sb .error404 .mh-main{max-width:1300px;}
.error404.mh-left-sb #main-content,
.mh-two-sb .error404 .mh-main{margin-right:0;float:none;}
.error404 .mh-content p{font-size:20px;}
.error404 .mh-box{background-color:#f1f09a;display:table;padding:20px;}
.error404 .mh-box p,
.error404 .mh-box span{display:table-cell;vertical-align:top;color:#000;}
.error404 .mh-box span{font-family:dashicons;font-size:36px;padding-right:30px;}
.error404 .mh-sidebar,
.error404 .mh-sidebar-wide{display:none;}
.mh-top-bar-sb .mh-top-bar{display:block;}
.mh-top-bar-sb .mh-top-bar.mh-widget{margin:0;}
.mh-top-bar-sb .mh-top-bar > .adplugg{width:100%;margin:0;padding:0;}
.mh-top-bar-sb .mh-widget-top-bar > .adplugg-tag{font-family:inherit;width:100%;}
.mh-widget-top-bar .adplugg-ad{height:80px;}
.mh-top-bar-sb .mh-top-bar .adplugg-ad-wrapper{position:fixed;z-index:110000;width:100%;}
.mh-top-bar-sb .mh-top-bar .adplugg-ad-wrapper > *{padding:14px;display:block;text-align:center;}
@media(max-width:768px){
.mh-widget-top-bar .adplugg-ad{height:110px;}
}
.mh-two-sb .mh-container{max-width:1456px;}
.mh-site-logo{background:transparent url('//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/70west-2_site-illos.png') no-repeat 100% center;background-size:54%;padding-bottom:40px;padding-top:40px;}
article.category-sponsored{background-color:#f4f3e9;padding:12px;box-sizing:border-box;}
.mh-container.mh-header-widget-1{display:table;}
.mh-header-widget-1 .mh-widget:first-child{width:50%;display:table-cell;}
.mh-header-widget-1 .mh-widget:last-child{width:50%;display:table-cell;}
.mh-header-widget-1 .mh-widget:first-child img{border-right:1px solid #fff;}
.mh-header-widget-1 .mh-widget:last-child img{border-left:1px solid #fff;}
.mh-excerpt-more{display:block;padding:0 10px;border:1px solid #e7e7e7;text-decoration:none;margin:5px 0;}
.mh-excerpt-more:hover{background-color:#7585B6;color:#ffffff;}
.to-categories{margin-bottom:25px;border-bottom:1px dotted #ebebeb;padding-bottom:0.3125rem;}
.to-categories a{color:#1A3585;text-transform:uppercase;font-weight:bold;}
.mh-widget{margin-bottom:10px;}
#livefyre-comments{padding-bottom:100px;}
.fyre-editor .fyre-editor-toolbar .fyre-share-button div.fyre-button-right-inner-box{padding:0 24px !important;}
@media(max-width:1024px){
body{font-size:16px;}
#mh-mobile .mh-header-1{margin:0;}
.mh-container.mh-header-widget-1{display:block;}
.mh-header-widget-1 .mh-widget:first-child,
.mh-header-widget-1 .mh-widget:last-child{width:100%;margin:0 auto;max-width:728px;margin:0 auto;display:block;}
.mh-header-widget-1 .mh-widget:first-child img,
.mh-header-widget-1 .mh-widget:last-child img{width:100%;margin:0 auto;border:0 none;max-width:728px;}
}
@media(max-width:768px){
.mh-site-logo{background-image:none;padding-bottom:20px;padding-top:20px;}
.mh-header-widget-1 .mh-widget:first-child,
.mh-header-widget-1 .mh-widget:last-child{margin:0;}
}</style>
<style>.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover{background:#38519a;}
.mh-extra-nav-bg{background:rgba(56, 81, 154, 0.2);}
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption{background:#38519a;background:rgba(56, 81, 154, 0.8);}
@media screen and (max-width:900px){ #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption{background:rgba(56, 81, 154, 1);}
}
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay{border-color:#38519a;}
.mh-copyright, .mh-copyright a{color:#fff;}
.mh-widget-layout4 .mh-widget-title{background:#1a3585;background:rgba(26, 53, 133, 0.6);}
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span{background:#1a3585;}
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover{border-color:#1a3585;}
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before{color:#1a3585;}
.entry-content a{color:#4a38ea;}
a:hover, .entry-content a:hover, #respond a:hover, #respond #cancel-comment-reply-link:hover, #respond .logged-in-as a:hover, .mh-comment-list .comment-meta a:hover, .mh-ping-list .mh-ping-item a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover{color:#b1161b;}</style>
<style>.entry-content{font-size:16px;font-size:1rem;}</style>
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_favicon-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_favicon-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_favicon-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://www.70westsentinel.com/scoop/wp-content/uploads/2016/12/cropped-70west_favicon-270x270.jpg"/>
<style>.ai-rotate{position:relative;}
.ai-rotate-hidden{visibility:hidden;}
.ai-rotate-hidden-2{position:absolute;top:0;left:0;width:100%;height:100%;}
.ai-list-data, .ai-ip-data, .ai-list-block{visibility:hidden;position:absolute;width:100%;height:100%;z-index:-9999;}</style>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-56508952-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-56508952-1');</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-148964 single-format-standard wp-custom-logo tribe-no-js mh-top-bar-sb mh-boxed-layout mh-left-sb mh-loop-layout1 mh-widget-layout4" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-widget mh-top-bar"></div><aside class="mh-container mh-header-widget-1">
<div id="ai_widget-5" class="mh-widget mh-header-1 ai_widget"><div class='code-block code-block-2' data-ai='WzIsIiIsIkxlYWRlcmJvYXJkIExlZnQiLCIiXQ==' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<div class='ai-rotate ai-2' data-info='WzIsMl0=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="a3NscQ==" data-time="OA=="> <a href="http://www.kslq.co/?utm_source=70westsentinel&utm_campaign=kslq"><img src="https://cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2018/08/kslq-todays-best.jpg"></a></div><div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="dGF0dG9lZGNhbnZhcw==" data-time="OA=="> <a href="https://thetattooedcanvas.com/page/28/private-parties?utm_source=70westsentinel&utm_campaign=tattooedcanvas"><img src="https://cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2018/08/tattooed-canvas-banner-728x90.jpg"></a></div></div></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div><div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-global-navigation-container"><ul id="menu-global-navigation" class="menu"><li id="menu-item-1264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1264"><a href="https://www.70westsentinel.com/about-70-west-sentinel/">About 70 West Sentinel</a></li> <li id="menu-item-606" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-606"><a href="https://www.70westsentinel.com/advertise-on-70-west-sentinel/">Advertising Opportunities</a></li> <li id="menu-item-848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-848"><a href="https://www.70westsentinel.com/subscribe-to-the-70-west-sentinel-newsletter/">Weekly Newsletter</a></li> <li id="menu-item-13411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13411"><a href="https://www.70westsentinel.com/subscribe-to-our-daily-news-alerts/">Daily News Alerts</a></li> <li id="menu-item-1568" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1568"><a href="https://www.70westsentinel.com/support-70-west-sentinel/">Support Local News</a></li> </ul></div></nav></div><div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-social-menu-container"><ul id="menu-social-menu" class="menu"><li id="menu-item-10216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10216"><a href="https://www.70westsentinel.com/feed/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">70 West Sentinel Feed</span></a></li> <li id="menu-item-10217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10217"><a href="https://www.facebook.com/pages/70-West-Sentinel/1385421705081587?ref=hl"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li> <li id="menu-item-10218" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10218"><a href="https://twitter.com/70WestSentinel"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li> <li id="menu-item-10219" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10219"><a href="https://plus.google.com/b/117040150402076780761/117040150402076780761/posts?pageId=117040150402076780761"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Google+</span></a></li> </ul></div></nav></div></div></div><header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-1 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand"> <a href="https://www.70westsentinel.com/" class="custom-logo-link" rel="home"><img width="593" height="91" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_site-logo.png" class="custom-logo" alt="70 West Sentinel" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_site-logo.png 593w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/12/cropped-70west_site-logo-336x52.png 336w" sizes="(max-width: 593px) 100vw, 593px"/></a></div></div></div></div></div><div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-new-navbar-menu-container"><ul id="menu-new-navbar-menu" class="menu"><li id="menu-item-5910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5910"><a href="https://www.70westsentinel.com/category/cities/">Cities</a> <ul class="sub-menu"> <li id="menu-item-5913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5913"><a href="https://www.70westsentinel.com/category/cities/wentzville/">Wentzville</a></li> <li id="menu-item-5912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5912"><a href="https://www.70westsentinel.com/category/cities/ofallon-2/">O&#8217;Fallon</a></li> <li id="menu-item-5911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5911"><a href="https://www.70westsentinel.com/category/cities/lake-saint-louis/">Lake Saint Louis</a></li> </ul> </li> <li id="menu-item-116001" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-116001"><a href="https://www.70westsentinel.com/latest-news/">News</a> <ul class="sub-menu"> <li id="menu-item-5924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5924"><a href="https://www.70westsentinel.com/category/police-fire/">Police &#038; Fire</a></li> <li id="menu-item-5915" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5915"><a href="https://www.70westsentinel.com/category/government-2/">Government</a></li> <li id="menu-item-5928" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5928"><a href="https://www.70westsentinel.com/category/business/">Business</a></li> <li id="menu-item-5925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5925"><a href="https://www.70westsentinel.com/category/schools/">Schools</a></li> <li id="menu-item-5914" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5914"><a href="https://www.70westsentinel.com/category/events/">Events</a></li> <li id="menu-item-5917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5917"><a href="https://www.70westsentinel.com/category/home-family/">Home &#038; Family</a></li> <li id="menu-item-5923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5923"><a href="https://www.70westsentinel.com/category/people/">People</a></li> <li id="menu-item-5916" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5916"><a href="https://www.70westsentinel.com/category/health/">Health</a></li> <li id="menu-item-5918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5918"><a href="https://www.70westsentinel.com/category/jobs/">Jobs</a></li> <li id="menu-item-5927" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5927"><a href="https://www.70westsentinel.com/category/volunteer-charity/">Volunteer &#038; Charity</a></li> <li id="menu-item-5921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5921"><a href="https://www.70westsentinel.com/category/obituaries/">Obituaries</a></li> </ul> </li> <li id="menu-item-5919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5919"><a href="https://www.70westsentinel.com/category/local-voices/">Local Voices</a> <ul class="sub-menu"> <li id="menu-item-5922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5922"><a href="https://www.70westsentinel.com/category/opinion/">Opinion</a></li> <li id="menu-item-5931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5931"><a href="https://www.70westsentinel.com/category/humor/">Humor</a></li> </ul> </li> <li id="menu-item-5926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5926"><a href="https://www.70westsentinel.com/category/upcoming-events/">Upcoming Events</a></li> <li id="menu-item-6052" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6052"><a href="http://70westsentinel.com/events">Events Calendar</a></li> </ul></div></nav></div></header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom"> Hot Topics<i class="fa fa-chevron-right"></i></div><div class="mh-ticker-content mh-ticker-content-bottom"> <ul id="mh-ticker-loop-bottom"> <li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/" title="St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ Mar. 27, 2020 5:16 PM ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Business </span> </a> </li> <li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.70westsentinel.com/st-charles-county-wic-program-services-still-available-staff-working-remotely-due-to-covid-19/" title="St. Charles County WIC program services still available; staff working remotely due to COVID-19"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ Mar. 27, 2020 4:00 PM ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> St. Charles County WIC program services still available; staff working remotely due to COVID-19 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Government </span> </a> </li> <li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.70westsentinel.com/employee-at-wentzville-post-office-tests-positive-for-covid-19/" title="Employee at Wentzville post office tests positive for COVID-19"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ Mar. 26, 2020 7:59 PM ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Employee at Wentzville post office tests positive for COVID-19 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Health </span> </a> </li> <li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.70westsentinel.com/st-charles-county-covid-19-update-24-positive-tests-as-of-march-26/" title="St. Charles County COVID-19 update: 24 positive tests as of March 26"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ Mar. 26, 2020 7:39 PM ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> St. Charles County COVID-19 update: 24 positive tests as of March 26 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Government </span> </a> </li> <li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://www.70westsentinel.com/three-residents-at-senior-facility-test-positive-for-covid-19/" title="Three residents at senior facility test positive for COVID-19"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ Mar. 26, 2020 3:48 PM ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Three residents at senior facility test positive for COVID-19 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Government </span> </a> </li> </ul></div></div></div></div><div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<div class="mh-header-date mh-header-date-bottom"> Mar. 27, 2020 5:21 PM</div></div></div></div><div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.70westsentinel.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.70westsentinel.com/category/business/" itemprop="url"><span itemprop="title">Business</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more</nav>
<div class="printfriendly"><a href="#" style="outline:none;" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png" alt="Print Friendly, PDF & Email"/></a></div><article id="post-148964" class="post-148964 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-government-2 category-health category-st-charles-county tag-food-safety tag-restaurant-inspections">
<header class="entry-header clearfix"><h1 class="entry-title">St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more</h1><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2020/03/">Mar. 27, 2020 5:16 PM</a></span> <span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.70westsentinel.com/category/business/" rel="category tag">Business</a>, <a href="https://www.70westsentinel.com/category/government-2/" rel="category tag">Government</a>, <a href="https://www.70westsentinel.com/category/health/" rel="category tag">Health</a>, <a href="https://www.70westsentinel.com/category/st-charles-county/" rel="category tag">St. Charles County</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#respond" class="mh-comment-count-link">0</a></span></div><div class="mh-meta entry-meta-author"><i class="fas fa-user"></i> <a href="https://www.70westsentinel.com/author/tam/" title="Posts by Tamara Duncan" class="author url fn" rel="author">Tamara Duncan</a></div></header>
<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg" alt="Burger and Beer" title="Burger and Beer"/>
<figcaption class="wp-caption-text">File photo</figcaption>
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F&t=St.+Charles+County+Food+Inspection+Scores%3A+Chillax%2C+Chilli%E2%80%99s%2C+Texas+Roadhouse%2C+McGurk%E2%80%99s%2C+and+more','facebookShare','width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=St.+Charles+County+Food+Inspection+Scores%3A+Chillax%2C+Chilli%E2%80%99s%2C+Texas+Roadhouse%2C+McGurk%E2%80%99s%2C+and+more:&url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F','twitterShare','width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F&source=','linkedinShare','width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F&media=https://www.70westsentinel.com/scoop/wp-content/uploads/2016/05/367816-20160511.jpg&description=St.+Charles+County+Food+Inspection+Scores%3A+Chillax%2C+Chilli%E2%80%99s%2C+Texas+Roadhouse%2C+McGurk%E2%80%99s%2C+and+more','pinterestShare','width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F','googleShare','width=626,height=436'); return false;" title="Share on Google+" target="_blank"> <span class="mh-share-button"><i class="fa fa-google-plus"></i></span> </a> <a class="mh-email" href="mailto:?subject=St.%20Charles%20County%20Food%20Inspection%20Scores%3A%20Chillax%2C%20Chilli%E2%80%99s%2C%20Texas%20Roadhouse%2C%20McGurk%E2%80%99s%2C%20and%20more&amp;body=https%3A%2F%2Fwww.70westsentinel.com%2Fst-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div><div class="pf-content"><p>The <a href="http://www.sccmo.org/413/Restaurant-Reports" target="_blank" rel="noopener noreferrer">St. Charles County Department of Public Health</a> monitors more than 1,300 food service providers in St. Charles County. (The City of St. Peters conducts its own inspections.) Routine inspections are conducted by specialists with the department for proper food safety procedures and are scored by deducting points from a starting score of 100.</p> <p><span id="more-29636"></span>The following acronyms are used in violation information: PHF (Potentially Hazardous Food), TCS (Time/Temperature Control for Safety), FCS (Food-contact Surface), NFC (Non-food contact surface), RTE (Read to Eat).</p> <p>The following scores were posted during the period of March 1 &#8211; 7, 2020. Comments in boxes are quoted from inspection forms.</p> <p><strong>Wentzville</strong></p> <ul> <li>Imo&#8217;s Pizza, 1127 West Pearce Boulevard &#8211; follow up, in compliance</li> <li>ALDI, 150 Crossroads South Drive &#8211; score 100</li> <li>Applebee&#8217;s, 1987 Wentzville Parkway &#8211; score 100</li> <li>909 Public House, 909 Main Plaza Drive &#8211; score 95</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Insufficient water capacity (includes hot water) 5(pnt) &#8211; </span><span class="s1">No hot water at the server hand sink.</span></p> </blockquote> <ul> <li>Village Center Care, 909 East Pitman Avenue &#8211; score 100</li> <li>Hawk&#8217;s Nest Liquor, 359 Luetkenhaus Boulevard &#8211; score 100</li> <li>Rizzo&#8217;s Bar and Grill, 1155 Wentzville Parkway Ste. 145 &#8211; score93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">No persons with a 5-year food safety manager training present at the time of inspection.</span></p> <p class="p1"><span class="s1">Thermometers missing from hot or cold unit 5(pnt) &#8211; </span><span class="s1">Thermometers missing from walk-in cooler, and RICs in kitchen.</span></p> </blockquote> <ul> <li>Chillax Tap Room and Co., 714 West Pearce Boulevard &#8211; 100 (opening)</li> <li>Las Lajas Mexican Store, 1126 West Pearce Boulevard 114 &#8211; score 100</li> <li>Millwoods, 1826 West Pearce Boulevard &#8211; score 100</li> <li>The Tattooed Dog, 11 Wentzville Bluffs Drive 109 &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Hand Sinks to be maintained clean and free of debris, stocked and available for use at all times.</span></p> <p class="p1"><span class="s1">Personal items to be properly stored away from food and food related items.</span></p> </blockquote> <ul> <li>Texas Roadhouse, 15150 Veterans Memorial Parkway &#8211; score 100</li> </ul> <p><strong>Lake Saint Louis</strong></p> <ul> <li>Hardee&#8217;s, 10 Centre on the Lake &#8211; score 98</li> <li>Pizza Hut, 8649 Highway N &#8211; score 100</li> <li>Sonic Drive-In, 6325 Ronald Reagan Drive &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Leaking plumbing or plumbing in disrepair 5, 2(pnt) &#8211; </span><span class="s1">Plumbing leaks rear 3 comp sink resulting in water on floor. in same area, walk in refrigeration drains into floor this should drain to drain line like other plumbing.</span></p> <p class="p1"><span class="s1">Unshielded bulbs 2(pnt)</span></p> </blockquote> <ul> <li>El Maguey Mexican Restaurant, 1413 Lake Saint Louis Boulevard &#8211; score 100</li> </ul> <p><strong>Dardenne Prairie</strong></p> <ul> <li>Barathaven Alzheimers Care Center, 1030 Barathaven Boulevard &#8211; score 100</li> <li>Red Robin, 7821 Highway N &#8211; score 100</li> </ul> <p><strong>St. Paul</strong></p> <ul> <li>Dog Prairie Tavern, 2348 Saint Paul Road &#8211; score 100</li> </ul> <p><strong>O’Fallon</strong></p> <ul> <li>Imo&#8217;s Pizza, 625 North Main Street &#8211; follow up, in compliance</li> <li>Fastlane, 7430 Highway N &#8211; score 100</li> <li>Barrels Taphouse and Grill, 6726 Highway N &#8211; follow up, in compliance</li> <li>Creative Corner, 1075 Highway P &#8211; score 100</li> <li>QuikTrip, 140 Fallon Loop Road &#8211; score 100</li> <li>Jack in the Box, 415 South Main Street &#8211; score 91</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">PHF?s not held at 41 degrees or below 5(pnt) &#8211; </span><span class="s1">Cut onions at make-table not being held at 41-degrees or below.</span></p> <p class="p1"><span class="s1">Vent hood dirty 2(pnt) &#8211; </span><span class="s1">Observed excess accumulation of debris on vents associated with hood over fryers.</span></p> <p class="p1"><span class="s1">Failure to post current, valid permit.</span></p> </blockquote> <ul> <li>Golden Corral, 1302 Bramblett Road &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Dirty NFCs 2(pnt)</span></p> <p class="p1"><span class="s1">OBSERVED WALK IN COOLER SHELVING SOILED IN COOKS COOLER </span></p> <p class="p1"><span class="s1">OBSERVED CAULKING AT PREP SINK SOILED </span></p> <p class="p1"><span class="s1">OBSERVED FISH REACH IN COOLER BOTTOM SHELF SOILED</span></p> <p class="p1"><span class="s1">Damaged floor tiles, holes in walls, missing ceiling tiles 2(pnt) &#8211; </span><span class="s1">OBSERVED HOLES IN WALLS BY HANDINK IN DISHROOM, DISHWASHER AREA AND BY HANDSINK AT DRINK STATION</span></p> </blockquote> <ul> <li>McGurk&#8217;s Public House, 108 South Main Street &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Warewashing machine did not have proper sanitizer concentration.</span></p> <p class="p1"><span class="s1">Failure to post current, valid permit.</span></p> </blockquote> <ul> <li>Bandana&#8217;s BBQ, 3446 Pheasant Meadow Drive &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">Celiling and walls of ice bin in need of cleaning to prevent build up.</span></p> <p class="p1"><span class="s1">Leaking plumbing or plumbing in disrepair 5, 2(pnt) &#8211; </span><span class="s1">Rear individual sink leaking at base and collecting drain water near slicer. 3 Comp Sink leaking at least 2 compartments</span></p> </blockquote> <ul> <li>Baskin-Robbins, 512 South Main Street &#8211; score 100</li> <li>Monkey Joe&#8217;s, 4732 Mid Rivers Mall &#8211; score 100</li> <li>Bright Start Academy, 864 Homefield Boulevard &#8211; score 98</li> <li>Piece of Cake Bakery, 114 Triad Center W &#8211; score 100</li> <li>Clayton&#8217;s, 104 Triad Center W &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">No test kit for sanitizer 5(pnt)  &#8211; </span><span class="s1">OBSERVED NO CHLORINE TEST STRIPS TO MEASURE SANITIZER LEVELS</span></p> <p class="p1"><span class="s1">Dirty NFCs 2(pnt)</span></p> <p class="p1"><span class="s1">-OBSERVED SODA GUN AT BAR SOILED </span></p> <p class="p1"><span class="s1">-OBSERVED SHELVING HOLDING PANS SOILED </span></p> <p class="p1"><span class="s1">-OBSERVED UTENSIL CONTAINER SOILED </span></p> <p class="p1"><span class="s1">-OBSERVED CAULKING BY DISHWASHER SOILED </span></p> <p class="p1"><span class="s1">-OBSERVED HOOD VENTS SOILED </span></p> <p class="p1"><span class="s1">-OBSERVED DOORS ON PREP COOLER DRAWERS SOILED</span></p> </blockquote> <ul> <li>Bleachers Bar &amp; Franks, 454 Highway P &#8211; score 89</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Sink used for purposes other than hand washing 5(pnt) &#8211; </span><span class="s1">Mats and other utensils being stored in bar handwashing sink.</span></p> <p class="p1"><span class="s1">Thermometers missing from hot or cold unit 2(pnt) &#8211; </span><span class="s1">Thermometers missing from cold units.</span></p> <p class="p1"><span class="s1">Equipment, linens, single service not stored properly 2(pnt) &#8211; </span><span class="s1">Bathroom in back of kitchen being used as storage for single-use items.</span></p> <p class="p1"><span class="s1">Vent hood dirty 2(pnt)</span></p> </blockquote> <ul> <li>Cracker Barrel, 120 Progress Point Court &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">Observed inside of some ice bins in need of cleaning to prevent build up. </span><span class="s1">Observed some soiling on high shelves and equipment tops and some air vents.</span></p> </blockquote> <ul> <li>Potbelly Sandwich Shop, 2027 Highway K &#8211; score 98</li> <li>Fritz&#8217;s Frozen Custard, 2453 Highway K &#8211; score 100</li> <li>Jersey Mike&#8217;s, 2508 Highway K &#8211; score 94</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Outer openings unprotected 2(pnt) &#8211; </span><span class="s1">OBSERVED CRACKED DRAIN COVER</span></p> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">OBSERVED SHELVING IN PREP COOLER AND DISPLAY COOLER SOILED</span></p> <p class="p1"><span class="s1">Leaking plumbing or plumbing in disrepair 5, 2(pnt) &#8211; </span><span class="s1">OBSERVED SMALL LEAK AT HANDSINK.</span></p> </blockquote> <ul> <li>Tap House Pub &amp; Patio, 9015 Veterans Memorial Parkway &#8211; score 94</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Found large air gap on exit door in the kitchen, located on the right side of the door.</span></p> <p class="p1"><span class="s1">Found gaskets in poor repair on cold holding units. </span></p> <p class="p1"><span class="s1">Found wood shelves with paint in poor condition. </span></p> <p class="p1"><span class="s1">Found rust developing on walk in cooler shelving</span></p> </blockquote> <ul> <li>Domino&#8217;s Pizza, 3441 Pheasant Meadow Drive 3 &#8211; score 90</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">One person should have 5 year certification and lead person on duty to have basic sanitation certification.</span></p> <p class="p1"><span class="s1">Leaking plumbing or plumbing in disrepair 5, 2(pnt) &#8211; </span><span class="s1">Plumbing at rear 3 compartment sink leaking in at least 2 places and should be maintained free of leaks.</span></p> </blockquote> <ul> <li>Dunkin Donuts/Baskin Robbins, 4009 Highway K &#8211; score 100</li> <li>Longhorn Steakhouse, 2102 Highway K &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">OBSERVED REACH IN FREEZER SHELVING SOILED.  </span><span class="s1">OBSERVED A COUPLE OF WALK IN COOLER SHELVES SOILED</span></p> <p class="p1"><span class="s1">Unshielded bulbs 2(pnt) &#8211; </span><span class="s1">LIGHT NEAR DISHWASHER WITHOUT PROTECTIVE COVER</span></p> </blockquote> <ul> <li>Texas Roadhouse of O&#8217;Fallon, 1600 Mexico Loop Road W &#8211; score 100</li> <li>Moudy&#8217;s Bar &amp; Grill, 2151 West Terra Lane &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Thermometers missing from hot or cold unit 5(pnt)</span></p> <p class="p1"><span class="s1">Vent hood dirty 2(pnt) &#8211; </span><span class="s1">Increase cleaning frequency of hood vents above fryers.</span></p> </blockquote> <ul> <li>Kids R Kids, 123 Hutchings Farm Drive &#8211; score 100</li> </ul> <p><strong>Cottleville</strong></p> <ul> <li>Glenfield Memory Care, 118 Ohmes Road &#8211; score 100</li> <li>Old Town Donuts, 3941 Mid Rivers Mall Drive &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Torn or broken door seals, hinges etc. (poorly maintained or in disrepair) 2(pnt) &#8211; </span><span class="s1">OBSERVED REACH IN COOLER GASKET IN NEED OF REPAIR</span></p> <p class="p1"><span class="s1">OBSERVED FLOORING SOILED BY FRYER. </span><span class="s1">OBSERVED FLOORING TILES BY FRYER IN NEED OF REPAIR ( HOLDING FOOD PARTICLES AND MOISTURE)</span></p> </blockquote> <ul> <li>Jo&#8217;s 5th Street Pub, 5205 Highway N &#8211; score 98</li> <li>Racanelli&#8217;s Pizza, 3945 Mid Rivers Mall Drive &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">PHF?s not held at 41 degrees or below 5(pnt) &#8211; </span><span class="s1">OBSERVED FOODS IN PREP COOLER AT 52 DEGREES</span></p> <p class="p1"><span class="s1">OBSERVED SANITIZER NOT WORKING IN DISHWASHER. ESTABLISHMENT IS USING 3 COMPARTMENT SINK.</span></p> </blockquote> <ul> <li>Salty&#8217;s Fresh Mex, 5045 Highway N &#8211; score 94</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Thermometers missing from hot or cold unit 2(pnt) &#8211; </span><span class="s1">OBSERVED THERMOMETERS MISSING FROM BAR REACH IN COOLER AND PREP COOLER IN KITCHEN</span></p> <p class="p1"><span class="s1">OBSERVED SHELVING IN REACH IN COOLER RUSTING AND PEELING PAINT</span></p> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">OBSERVED SHELVING BY PREP COOLER HEAVILY SOILED </span></p> <p class="p1"><span class="s1">OBSERVED ICE MACHINE SHELF SOILED </span></p> <p class="p1"><span class="s1">OBSERVED SHELF UNDER GRILL SOILED</span></p> </blockquote> <ul> <li>La Chata, 3891 Mid Rivers Mall Drive &#8211; score 91</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">PHF?s not held at 41 degrees or below 5(pnt) &#8211; </span><span class="s1">OBSERVED FOODS IN REACH IN COOLER AT 50 DEGREES</span></p> <p class="p1"><span class="s1">Torn or broken door seals, hinges etc. (poorly maintained or in disrepair) 2(pnt) &#8211; </span><span class="s1">OBSERVED GASKETS IN NEED OF REPLACEMENT IN WALK IN COOLER AND PREP COOLER. </span><span class="s1">OBSERVED WALK IN COOLER SHELVING STARTING TO RUST</span></p> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">OBSERVED FLOORING SOILED IN DRY STORAGE AREA AND KITCHEN AREA</span></p> </blockquote> <p><strong>St. Charles</strong></p> <ul> <li>Tucano&#8217;s Brazilian Grill, 1520 South Fifth Street &#8211; score 98</li> <li>Holiday Inn Express, 3098 Elm Point Industrial Drive &#8211; score 98</li> <li>Circle K, 3700 Elm Street &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Dirty NFCs 2(pnt) &#8211; </span><span class="s1">Observed shelving in walk in cooler (display merch shelving) with accumulation of debris. Require cleaning at increased frequency.</span></p> <p class="p1"><span class="s1">Coats, purses and other personal items stored improperly 2(pnt) &#8211; </span><span class="s1">Observed coats hung on shelving. Must have designated location away from food prep/cooking/storage areas for personal items to be stored.</span></p> </blockquote> <ul> <li>Lewis and Clark Gardens, 1221 Boones Lick Road &#8211; score 100</li> <li>Thai Kitchen, 2436 West Clay Street &#8211; score 95</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Sink is blocked or inaccessible 5(pnt) &#8211; </span><span class="s1">Observed kitchen handwash sink inaccessible (bag of oranges and kitchen equipment stored in sink). Corrected on-site.</span></p> </blockquote> <ul> <li>AFC Sushi at Schnuck&#8217;s, 1900 First Capitol Drive &#8211; score 95</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"><p><span class="s1">No person in charge with a 5 year management level food safety certification.</span></p></blockquote> <ul> <li>Duchesne Bar, 1001 South Duchesne Drive &#8211; score 95</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Observed most recent health inspection not printed and posted for public viewing.</span></p> </blockquote> <ul> <li>Sleep Inn &amp; Suites, 150 Fountain Lakes Boulevard &#8211; score 93</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">No person in charge with minimum requirement for food safety certification. Only basic level training required. Any ANSI accredited program allowed. Two examples include ServSafe food handler or foodhandlerclasses.com.</span></p> <p class="p1"><span class="s1">Found cabinets in poor condition. Found water damage to cabinets and cabinet shelving below water sources/sinks.</span></p> </blockquote> <ul> <li>Mr Thirsty&#8217;s Bar &amp; Grill, 324 North Main Street &#8211; score 91</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Ready to eat PHFs not dated 5(pnt) &#8211; </span><span class="s1">Found soups in walk in cooler without dates and labels. Must be marked with date that item was prepared or marked with a discard date of 7 days. </span></p> <p class="p1"><span class="s1">Found hoods requiring professional cleaning service. </span></p> <p class="p1"><span class="s1">Found floors around fryers with accumulation of </span><span class="s1">grease. </span></p> <p class="p1"><span class="s1">Found walk in cooler shelving with rust buildup.</span></p> <p class="p1"><span class="s1">Grease trap with strong aroma. Requires cleaning and inspection by professional servicing company. Last cleaned September 2019.</span></p> </blockquote> <ul> <li>Donut King, 658 First Capitol Drive &#8211; score 98</li> <li>Missouri Bluffs Golf Club, 18 Research Park Circle &#8211; score 100</li> <li>Pizza Hut, 2440 West Clay Street &#8211; score 96</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">Shelving found heavily soiled throughout facility. Areas include (but not limited to): </span></p> <p class="p1"><span class="s1">Shelves in Walk in cooler </span></p> <p class="p1"><span class="s1">Shelves Over prep area table and under prep table </span></p> <p class="p1"><span class="s1">Shelves by fryer on both sides </span></p> <p class="p1"><span class="s1">Shelves under and above pizza cutting/boxing table </span></p> <p class="p1"><span class="s1">Found hood and hood vents with accumulation of grease. No sticker found with last cleaning/servicing date. Requires professional cleaning.</span></p> <p class="p1"><span class="s1">Found floors under prep table and wall of walk in cooler with excessive oil and debris accumulation.</span></p> </blockquote> <ul> <li>Big Richard&#8217;s Hot Dogs, 1502 Elm Street &#8211; score 100</li> </ul> <p><strong>Weldon Spring</strong></p> <ul> <li>Breeze Park, 600 Breeze Park Drive &#8211; score 100</li> <li>Mattingly&#8217;s Sports Bar &amp; Grill, 1048 Wolfrum Road &#8211; score 88</li> </ul> <blockquote style="border: 2px solid #666; padding: 10px; background-color: #ccc;"> <p class="p1"><span class="s1">No towels or dryer at sink 5(pnt)</span></p> <p class="p1"><span class="s1">Raw meats above RTE food 5(pnt)</span></p> <p class="p1"><span class="s1">Facility is operating without valid food permit</span></p> <p class="p1"><span class="s1">Plumbing at 3 comp sink is taken apart. Needs to be repaired.  </span><span class="s1">Shelving and equipment such as microwave in need of cleaning to prevent contamination. </span></p> </blockquote> <p><strong>St. Peters</strong></p> <p>The City of St. Peters conducts its own inspections through its <a href="https://www.stpetersmo.net/food-sanitation.aspx#RestaurantInspections" target="_blank" rel="noopener noreferrer">Food Sanitation Department</a>. Violation details are not available. The following inspection scores are from January 2020</p> <ul> <li>Ben.e.fit Fitness &amp; Nutrition, 3004 S. St. Peters Parkway Ste. A &#8211; score 100</li> <li>Bento Sushi Bar at Dierberg&#8217;s, 6211 Mid Rivers Mall Drive &#8211; score 100</li> <li>Big Lots, 5881 Suemandy Road &#8211; score 100</li> <li>Brick Oven, 84 Spencer &#8211; score 94</li> <li>Brookdale St. Peters, 363 Jungermann Road &#8211; score 98</li> <li>Cake by Georgia, 7338 Mexico Road &#8211; score 100</li> <li>Charley&#8217;s Philly Steaks, 1600 Mid Rivers Mall Drive Ste. 1204 &#8211; score 100</li> <li>Chestnut Glenn Assisted Living by Americare, 121 Klondike Crossing &#8211; score 86 (Jan. 13), score 96 (Jan. 23)</li> <li>Chicken Coop, 449 South Church Street &#8211; score 100</li> <li>Chili&#8217;s Grill &amp; Bar, 101 Mid Rivers Mall Circle &#8211; score 96</li> </ul></div></div><div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://www.70westsentinel.com/tag/food-safety/" rel="tag">Food Safety</a></li><li><a href="https://www.70westsentinel.com/tag/restaurant-inspections/" rel="tag">Restaurant Inspections</a></li></ul></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev"> <a href="https://www.70westsentinel.com/st-charles-county-wic-program-services-still-available-staff-working-remotely-due-to-covid-19/" rel="prev"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="baby with bottle" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-80x60.jpg 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-336x252.jpg 336w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-400x300.jpg 400w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-500x375.jpg 500w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-326x245.jpg 326w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640-600x450.jpg 600w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2017/04/baby-105063_640.jpg 640w" sizes="(max-width: 80px) 100vw, 80px"/><span>Previous</span><p>St. Charles County WIC program services still available; staff working remotely due to COVID-19</p></a></div></nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.70westsentinel.com/scoop/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<div class="g-recaptcha-wrap" style="padding:10px 0 10px 0"><div class="g-recaptcha" data-sitekey="6LeRv3wUAAAAABay3vIpnQ3t0FKuPpaetvSQk9O5"></div></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='148964' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cd6b928eef" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="163"/></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="mh_magazine_custom_pages-3" class="mh-widget mh_magazine_custom_pages"> <ul class="mh-custom-posts-widget mh-custom-pages-widget clearfix"> </ul></div><div id="mh_magazine_tabbed-2" class="mh-widget mh_magazine_tabbed">			<div class="mh-tabbed-widget">
<div class="mh-tab-buttons clearfix"> <a class="mh-tab-button" href="#tab-mh_magazine_tabbed-2-1"> <span><i class="fa fa-newspaper-o"></i></span> </a> <a class="mh-tab-button" href="#tab-mh_magazine_tabbed-2-2"> <span><i class="fa fa-tags"></i></span> </a> <a class="mh-tab-button" href="#tab-mh_magazine_tabbed-2-3"> <span><i class="fa fa-comments-o"></i></span> </a></div><div id="tab-mh_magazine_tabbed-2-1" class="mh-tab-content mh-tab-posts"><ul class="mh-tab-content-posts"> <li class="mh-tab-post-item post-148964 post type-post status-publish format-standard has-post-thumbnail category-business category-government-2 category-health category-st-charles-county tag-food-safety tag-restaurant-inspections"> <a href="https://www.70westsentinel.com/st-charles-county-food-inspection-scores-chillax-chillis-texas-roadhouse-mcgurks-and-more/"> St. Charles County Food Inspection Scores: Chillax, Chilli&#8217;s, Texas Roadhouse, McGurk&#8217;s, and more </a> </li> <li class="mh-tab-post-item post-148954 post type-post status-publish format-standard has-post-thumbnail category-government-2 category-health category-st-charles-county"> <a href="https://www.70westsentinel.com/st-charles-county-wic-program-services-still-available-staff-working-remotely-due-to-covid-19/"> St. Charles County WIC program services still available; staff working remotely due to COVID-19 </a> </li> <li class="mh-tab-post-item post-148889 post type-post status-publish format-standard has-post-thumbnail category-health category-wentzville tag-coronavirus"> <a href="https://www.70westsentinel.com/employee-at-wentzville-post-office-tests-positive-for-covid-19/"> Employee at Wentzville post office tests positive for COVID-19 </a> </li> <li class="mh-tab-post-item post-148887 post type-post status-publish format-standard has-post-thumbnail category-government-2 category-health category-st-charles-county tag-coronavirus"> <a href="https://www.70westsentinel.com/st-charles-county-covid-19-update-24-positive-tests-as-of-march-26/"> St. Charles County COVID-19 update: 24 positive tests as of March 26 </a> </li> <li class="mh-tab-post-item post-148865 post type-post status-publish format-standard has-post-thumbnail category-government-2 category-health category-st-charles-county tag-coronavirus"> <a href="https://www.70westsentinel.com/three-residents-at-senior-facility-test-positive-for-covid-19/"> Three residents at senior facility test positive for COVID-19 </a> </li> <li class="mh-tab-post-item post-148802 post type-post status-publish format-standard has-post-thumbnail category-government-2 category-health category-recreation category-wentzville tag-coronavirus tag-covid-19"> <a href="https://www.70westsentinel.com/wentzville-closes-playgrounds-extends-recreation-facilities-closures-through-may-3/"> Wentzville closes playgrounds, extends recreation facilities closures through May 3 </a> </li></ul></div><div id="tab-mh_magazine_tabbed-2-2" class="mh-tab-content mh-tab-cloud">
<div class="tagcloud mh-tab-content-cloud"> <a href="https://www.70westsentinel.com/tag/arrests/" class="tag-cloud-link tag-link-61 tag-link-position-1" style="font-size: 12px;">Arrests</a> <a href="https://www.70westsentinel.com/tag/arts-and-entertainment/" class="tag-cloud-link tag-link-208 tag-link-position-2" style="font-size: 12px;">Arts and Entertainment</a> <a href="https://www.70westsentinel.com/tag/bingo/" class="tag-cloud-link tag-link-974 tag-link-position-3" style="font-size: 12px;">Bingo</a> <a href="https://www.70westsentinel.com/tag/crash/" class="tag-cloud-link tag-link-55 tag-link-position-4" style="font-size: 12px;">Crash</a> <a href="https://www.70westsentinel.com/tag/crime/" class="tag-cloud-link tag-link-60 tag-link-position-5" style="font-size: 12px;">Crime</a> <a href="https://www.70westsentinel.com/tag/deaths/" class="tag-cloud-link tag-link-64 tag-link-position-6" style="font-size: 12px;">Deaths</a> <a href="https://www.70westsentinel.com/tag/dwi/" class="tag-cloud-link tag-link-98 tag-link-position-7" style="font-size: 12px;">DWI</a> <a href="https://www.70westsentinel.com/tag/employment/" class="tag-cloud-link tag-link-125 tag-link-position-8" style="font-size: 12px;">Employment</a> <a href="https://www.70westsentinel.com/tag/farmers-market/" class="tag-cloud-link tag-link-215 tag-link-position-9" style="font-size: 12px;">Farmers Market</a> <a href="https://www.70westsentinel.com/tag/festivals/" class="tag-cloud-link tag-link-133 tag-link-position-10" style="font-size: 12px;">festivals</a> <a href="https://www.70westsentinel.com/tag/fireworks/" class="tag-cloud-link tag-link-341 tag-link-position-11" style="font-size: 12px;">Fireworks</a> <a href="https://www.70westsentinel.com/tag/flea-market/" class="tag-cloud-link tag-link-347 tag-link-position-12" style="font-size: 12px;">Flea Market</a> <a href="https://www.70westsentinel.com/tag/food-safety/" class="tag-cloud-link tag-link-287 tag-link-position-13" style="font-size: 12px;">Food Safety</a> <a href="https://www.70westsentinel.com/tag/funeral-services/" class="tag-cloud-link tag-link-150 tag-link-position-14" style="font-size: 12px;">Funeral Services</a> <a href="https://www.70westsentinel.com/tag/lake-st-louis/" class="tag-cloud-link tag-link-58 tag-link-position-15" style="font-size: 12px;">Lake St. Louis</a> <a href="https://www.70westsentinel.com/tag/missouri-state-highway-patrol/" class="tag-cloud-link tag-link-70 tag-link-position-16" style="font-size: 12px;">Missouri State Highway Patrol</a> <a href="https://www.70westsentinel.com/tag/new-business/" class="tag-cloud-link tag-link-117 tag-link-position-17" style="font-size: 12px;">New Business</a> <a href="https://www.70westsentinel.com/tag/ofallon-police-department/" class="tag-cloud-link tag-link-165 tag-link-position-18" style="font-size: 12px;">O&#039;Fallon Police Department</a> <a href="https://www.70westsentinel.com/tag/restaurant-inspections/" class="tag-cloud-link tag-link-286 tag-link-position-19" style="font-size: 12px;">Restaurant Inspections</a> <a href="https://www.70westsentinel.com/tag/rezoning/" class="tag-cloud-link tag-link-281 tag-link-position-20" style="font-size: 12px;">Rezoning</a> <a href="https://www.70westsentinel.com/tag/st-charles-community-college/" class="tag-cloud-link tag-link-330 tag-link-position-21" style="font-size: 12px;">St. Charles Community College</a> <a href="https://www.70westsentinel.com/tag/st-charles-county-department-of-community-health-and-the-environment/" class="tag-cloud-link tag-link-231 tag-link-position-22" style="font-size: 12px;">St. Charles County Department of Community Health and the Environment</a> <a href="https://www.70westsentinel.com/tag/st-charles-county-department-of-public-health/" class="tag-cloud-link tag-link-1019 tag-link-position-23" style="font-size: 12px;">St. Charles County Department of Public Health</a> <a href="https://www.70westsentinel.com/tag/wentzville-police-department/" class="tag-cloud-link tag-link-71 tag-link-position-24" style="font-size: 12px;">Wentzville Police Department</a> <a href="https://www.70westsentinel.com/tag/wentzville-school-district/" class="tag-cloud-link tag-link-66 tag-link-position-25" style="font-size: 12px;">Wentzville School District</a></div></div><div id="tab-mh_magazine_tabbed-2-3" class="mh-tab-content mh-tab-comments"><ul class="mh-tab-content-comments"> <li class="mh-tab-comment-item"> <span class="mh-tab-comment-avatar"> </span> <span class="mh-tab-comment-author"> Brooke: </span> <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1495"> <span class="mh-tab-comment-excerpt"> Are you looking at the survivable rate of Covid-19? Because so far I'm no expert or anything but far more&hellip; </span> </a> </li> <li class="mh-tab-comment-item"> <span class="mh-tab-comment-avatar"> </span> <span class="mh-tab-comment-author"> Brooke: </span> <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1494"> <span class="mh-tab-comment-excerpt"> Ummm your pets food is not essential to your survival you do not need a pet to live yourself (unless&hellip; </span> </a> </li> <li class="mh-tab-comment-item"> <span class="mh-tab-comment-avatar"> </span> <span class="mh-tab-comment-author"> Brooke: </span> <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1493"> <span class="mh-tab-comment-excerpt"> Oh and one more thing the virus is spreading more quickly at gas stations from people pumping gas than it&hellip; </span> </a> </li></ul></div></div></div><div id="tribe-mini-calendar-2" class="mh-widget tribe_mini_calendar_widget"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Events Calendar</span></h4>
<div class="tribe-mini-calendar-wrapper">
<div class="tribe-mini-calendar-grid-wrapper">
<table class="tribe-mini-calendar"  data-count="5" data-eventDate="2020-03-01" data-tax-query="[]" data-nonce="10a7f90d7d">
<thead class="tribe-mini-calendar-nav">
<tr>
<td colspan="7">
<div> <a class="tribe-mini-calendar-nav-link prev-month" href="#" data-month="2020-02-01" title="February"><span>&laquo;</span></a> <span id="tribe-mini-calendar-month-0">Mar 2020</span> <a class="tribe-mini-calendar-nav-link next-month" href="#" data-month="2020-04-01" title="April"><span>&raquo;</span></a> <img id="ajax-loading-mini" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/plugins/the-events-calendar/src/resources/images/tribe-loading.gif" alt="loading..."/></div></td>
</tr>
<tr>
<th class="tribe-mini-calendar-dayofweek">M</th>
<th class="tribe-mini-calendar-dayofweek">T</th>
<th class="tribe-mini-calendar-dayofweek">W</th>
<th class="tribe-mini-calendar-dayofweek">T</th>
<th class="tribe-mini-calendar-dayofweek">F</th>
<th class="tribe-mini-calendar-dayofweek">S</th>
<th class="tribe-mini-calendar-dayofweek">S</th>
</tr>
</thead>
<tbody>
<tr>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-24">
<div id="daynum-24-0"> <span class="tribe-mini-calendar-no-event">24</span></div></td>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-25">
<div id="daynum-25-0"> <span class="tribe-mini-calendar-no-event">25</span></div></td>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-26">
<div id="daynum-26-0"> <span class="tribe-mini-calendar-no-event">26</span></div></td>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-27">
<div id="daynum-27-0"> <span class="tribe-mini-calendar-no-event">27</span></div></td>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-28 tribe-events-right">
<div id="daynum-28-0"> <span class="tribe-mini-calendar-no-event">28</span></div></td>
<td class="tribe-events-othermonth tribe-events-past mobile-trigger tribe-event-day-29 tribe-events-right">
<div id="daynum-29-0"> <span class="tribe-mini-calendar-no-event">29</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-01 tribe-events-right">
<div id="daynum-1-0"> <span class="tribe-mini-calendar-no-event">1</span></div></td>
</tr>
<tr>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-02">
<div id="daynum-2-0"> <span class="tribe-mini-calendar-no-event">2</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-03">
<div id="daynum-3-0"> <span class="tribe-mini-calendar-no-event">3</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-04">
<div id="daynum-4-0"> <span class="tribe-mini-calendar-no-event">4</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-05">
<div id="daynum-5-0"> <span class="tribe-mini-calendar-no-event">5</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-06 tribe-events-right">
<div id="daynum-6-0"> <span class="tribe-mini-calendar-no-event">6</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-07 tribe-events-right">
<div id="daynum-7-0"> <span class="tribe-mini-calendar-no-event">7</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-08 tribe-events-right">
<div id="daynum-8-0"> <span class="tribe-mini-calendar-no-event">8</span></div></td>
</tr>
<tr>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-09">
<div id="daynum-9-0"> <span class="tribe-mini-calendar-no-event">9</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-10">
<div id="daynum-10-0"> <span class="tribe-mini-calendar-no-event">10</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-11">
<div id="daynum-11-0"> <span class="tribe-mini-calendar-no-event">11</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-12">
<div id="daynum-12-0"> <span class="tribe-mini-calendar-no-event">12</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-13 tribe-events-right">
<div id="daynum-13-0"> <span class="tribe-mini-calendar-no-event">13</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-14 tribe-events-right">
<div id="daynum-14-0"> <span class="tribe-mini-calendar-no-event">14</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-15 tribe-events-right">
<div id="daynum-15-0"> <span class="tribe-mini-calendar-no-event">15</span></div></td>
</tr>
<tr>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-16">
<div id="daynum-16-0"> <span class="tribe-mini-calendar-no-event">16</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-17">
<div id="daynum-17-0"> <span class="tribe-mini-calendar-no-event">17</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-18">
<div id="daynum-18-0"> <span class="tribe-mini-calendar-no-event">18</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-19">
<div id="daynum-19-0"> <span class="tribe-mini-calendar-no-event">19</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-20 tribe-events-right">
<div id="daynum-20-0"> <span class="tribe-mini-calendar-no-event">20</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-21 tribe-events-right">
<div id="daynum-21-0"> <span class="tribe-mini-calendar-no-event">21</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-22 tribe-events-right">
<div id="daynum-22-0"> <span class="tribe-mini-calendar-no-event">22</span></div></td>
</tr>
<tr>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-23">
<div id="daynum-23-0"> <span class="tribe-mini-calendar-no-event">23</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-24">
<div id="daynum-24-1"> <span class="tribe-mini-calendar-no-event">24</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-25">
<div id="daynum-25-1"> <span class="tribe-mini-calendar-no-event">25</span></div></td>
<td class="tribe-events-thismonth tribe-events-past mobile-trigger tribe-event-day-26">
<div id="daynum-26-1"> <span class="tribe-mini-calendar-no-event">26</span></div></td>
<td class="tribe-events-thismonth tribe-events-present mobile-trigger tribe-event-day-27 tribe-events-right">
<div id="daynum-27-1"> <span class="tribe-mini-calendar-no-event">27</span></div></td>
<td class="tribe-events-thismonth tribe-events-future mobile-trigger tribe-event-day-28 tribe-events-right">
<div id="daynum-28-1"> <span class="tribe-mini-calendar-no-event">28</span></div></td>
<td class="tribe-events-thismonth tribe-events-future mobile-trigger tribe-event-day-29 tribe-events-right">
<div id="daynum-29-1"> <span class="tribe-mini-calendar-no-event">29</span></div></td>
</tr>
<tr>
<td class="tribe-events-thismonth tribe-events-future mobile-trigger tribe-event-day-30">
<div id="daynum-30-0"> <span class="tribe-mini-calendar-no-event">30</span></div></td>
<td class="tribe-events-thismonth tribe-events-future mobile-trigger tribe-event-day-31">
<div id="daynum-31-0"> <span class="tribe-mini-calendar-no-event">31</span></div></td>
<td class="tribe-events-othermonth tribe-events-future mobile-trigger tribe-event-day-01">
<div id="daynum-1-1"> <span class="tribe-mini-calendar-no-event">1</span></div></td>
<td class="tribe-events-othermonth tribe-events-future mobile-trigger tribe-event-day-02">
<div id="daynum-2-1"> <span class="tribe-mini-calendar-no-event">2</span></div></td>
<td class="tribe-events-othermonth tribe-events-future mobile-trigger tribe-event-day-03 tribe-events-right">
<div id="daynum-3-1"> <span class="tribe-mini-calendar-no-event">3</span></div></td>
<td class="tribe-events-othermonth tribe-events-future mobile-trigger tribe-event-day-04 tribe-events-right">
<div id="daynum-4-1"> <span class="tribe-mini-calendar-no-event">4</span></div></td>
<td class="tribe-events-othermonth tribe-events-future mobile-trigger tribe-event-day-05 tribe-events-right">
<div id="daynum-5-1"> <span class="tribe-mini-calendar-no-event">5</span></div></td>
</tr>
</tbody>
</table></div><div class="tribe-mini-calendar-list-wrapper">
<div class="tribe-events-loop"></div></div></div></div><div id="recent-comments-3" class="mh-widget widget_recent_comments"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Comments</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Brooke</span> on <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1495">Ehlmann says St. Charles County will not follow St. Louis County and St. Louis City stay-at-home order</a></li><li class="recentcomments"><span class="comment-author-link">Brooke</span> on <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1494">Ehlmann says St. Charles County will not follow St. Louis County and St. Louis City stay-at-home order</a></li><li class="recentcomments"><span class="comment-author-link">Brooke</span> on <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1493">Ehlmann says St. Charles County will not follow St. Louis County and St. Louis City stay-at-home order</a></li><li class="recentcomments"><span class="comment-author-link">Brooke</span> on <a href="https://www.70westsentinel.com/ehlmann-says-st-charles-county-will-not-follow-st-louis-county-and-st-louis-city-stay-at-home-order/#comment-1492">Ehlmann says St. Charles County will not follow St. Louis County and St. Louis City stay-at-home order</a></li><li class="recentcomments"><span class="comment-author-link">Debra S Kueck</span> on <a href="https://www.70westsentinel.com/st-charles-county-reports-first-covid-19-death/#comment-1489">St. Charles County reports first COVID-19 death</a></li></ul></div></aside></div><aside class="mh-widget-col-1 mh-sidebar-2 mh-sidebar-wide" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<div id="mh_magazine_custom_posts-8" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://www.70westsentinel.com/category/sponsored/" class="mh-widget-title-link">Sponsored</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-148548 post type-post status-publish format-standard has-post-thumbnail category-sponsored"> <figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.70westsentinel.com/crazy-bowls-wraps-offering-free-delivery-with-doordash/" title="Crazy Bowls &#038; Wraps offering free delivery with DoorDash"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/new-crazy-content84-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/new-crazy-content84-80x60.jpg 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/new-crazy-content84-678x509.jpg 678w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/new-crazy-content84-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px"/> </a> </figure> <div class="mh-custom-posts-header"> <div class="mh-custom-posts-small-title"> <a href="https://www.70westsentinel.com/crazy-bowls-wraps-offering-free-delivery-with-doordash/" title="Crazy Bowls &#038; Wraps offering free delivery with DoorDash"> Crazy Bowls &#038; Wraps offering free delivery with DoorDash </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2020/03/">Mar. 22, 2020 4:04 PM</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/crazy-bowls-wraps-offering-free-delivery-with-doordash/#respond" class="mh-comment-count-link">0</a></span></div></div></li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-148540 post type-post status-publish format-standard has-post-thumbnail category-sponsored"> <figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.70westsentinel.com/909-public-house-in-wentzville-offering-curbside-no-contact-delivery/" title="909 Public House in Wentzville offering curbside, no contact delivery"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-22-at-2.44.00-PM-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-22-at-2.44.00-PM-80x60.png 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-22-at-2.44.00-PM-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px"/> </a> </figure> <div class="mh-custom-posts-header"> <div class="mh-custom-posts-small-title"> <a href="https://www.70westsentinel.com/909-public-house-in-wentzville-offering-curbside-no-contact-delivery/" title="909 Public House in Wentzville offering curbside, no contact delivery"> 909 Public House in Wentzville offering curbside, no contact delivery </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2020/03/">Mar. 22, 2020 2:45 PM</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/909-public-house-in-wentzville-offering-curbside-no-contact-delivery/#respond" class="mh-comment-count-link">0</a></span></div></div></li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-148529 post type-post status-publish format-standard has-post-thumbnail category-business category-ofallon-2 category-sponsored category-wentzville"> <figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.70westsentinel.com/imos-in-wentzville-and-ofallon-offering-deal-on-frozen-pizzas/" title="IMO&#8217;s in Wentzville and O&#8217;Fallon offering deal on frozen pizzas"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-80x60.jpg 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-336x252.jpg 336w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-771x578.jpg 771w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-768x576.jpg 768w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-400x300.jpg 400w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-500x375.jpg 500w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-678x509.jpg 678w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248-326x245.jpg 326w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/20200322_123248.jpg 800w" sizes="(max-width: 80px) 100vw, 80px"/> </a> </figure> <div class="mh-custom-posts-header"> <div class="mh-custom-posts-small-title"> <a href="https://www.70westsentinel.com/imos-in-wentzville-and-ofallon-offering-deal-on-frozen-pizzas/" title="IMO&#8217;s in Wentzville and O&#8217;Fallon offering deal on frozen pizzas"> IMO&#8217;s in Wentzville and O&#8217;Fallon offering deal on frozen pizzas </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2020/03/">Mar. 22, 2020 1:57 PM</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/imos-in-wentzville-and-ofallon-offering-deal-on-frozen-pizzas/#comments" class="mh-comment-count-link">4</a></span></div></div></li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-148450 post type-post status-publish format-standard has-post-thumbnail category-business category-ofallon-2 category-sponsored category-wentzville"> <figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.70westsentinel.com/wentzville-ofallon-burger-kings-to-offer-free-kids-meals-with-adult-meal-purchase/" title="Wentzville, O&#8217;Fallon Burger Kings to offer free kids meals with adult meal purchase"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-20-at-7.58.28-PM-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-20-at-7.58.28-PM-80x60.png 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-20-at-7.58.28-PM-678x509.png 678w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2020/03/Screen-Shot-2020-03-20-at-7.58.28-PM-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px"/> </a> </figure> <div class="mh-custom-posts-header"> <div class="mh-custom-posts-small-title"> <a href="https://www.70westsentinel.com/wentzville-ofallon-burger-kings-to-offer-free-kids-meals-with-adult-meal-purchase/" title="Wentzville, O&#8217;Fallon Burger Kings to offer free kids meals with adult meal purchase"> Wentzville, O&#8217;Fallon Burger Kings to offer free kids meals with adult meal purchase </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2020/03/">Mar. 20, 2020 8:02 PM</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/wentzville-ofallon-burger-kings-to-offer-free-kids-meals-with-adult-meal-purchase/#respond" class="mh-comment-count-link">0</a></span></div></div></li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-132530 post type-post status-publish format-standard has-post-thumbnail category-holiday category-recreation category-sponsored category-upcoming-events category-wentzville tag-arts-and-crafts"> <figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.70westsentinel.com/crossroad-arts-council-offering-holiday-arts-and-crafts-classes/" title="Crossroad Arts Council offering holiday arts and crafts classes"><img width="80" height="60" src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM-80x60.png 80w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM-336x247.png 336w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM-400x294.png 400w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM-326x245.png 326w, //cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2019/11/Screen-Shot-2019-11-17-at-11.27.11-AM.png 493w" sizes="(max-width: 80px) 100vw, 80px"/> </a> </figure> <div class="mh-custom-posts-header"> <div class="mh-custom-posts-small-title"> <a href="https://www.70westsentinel.com/crossroad-arts-council-offering-holiday-arts-and-crafts-classes/" title="Crossroad Arts Council offering holiday arts and crafts classes"> Crossroad Arts Council offering holiday arts and crafts classes </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.70westsentinel.com/2019/11/">Nov. 17, 2019 11:31 AM</a></span> <span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.70westsentinel.com/crossroad-arts-council-offering-holiday-arts-and-crafts-classes/#respond" class="mh-comment-count-link">0</a></span></div></div></li>			</ul></div></aside></div><footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-1">
<div id="text-9" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">About</span></h6>			<div class="textwidget">70 West Sentinel is an online source for news, information, and issues of importance to cities along the I-70 corridor in St. Charles and Warren Counties in Missouri. Contact Editor/Publisher Tammy Duncan by email at tammy@70westsentinel.com</div></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-2">
<div id="mh_magazine_social-2" class="mh-footer-widget mh_magazine_social"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Stay connected</span></h6>				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-menu-container"><ul id="menu-social-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10216"><a href="https://www.70westsentinel.com/feed/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">70 West Sentinel Feed</span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10217"><a href="https://www.facebook.com/pages/70-West-Sentinel/1385421705081587?ref=hl"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10218"><a href="https://twitter.com/70WestSentinel"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10219"><a href="https://plus.google.com/b/117040150402076780761/117040150402076780761/posts?pageId=117040150402076780761"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Google+</span></a></li> </ul></div></nav></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-3">
<div id="text-18" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">70 West Sentinel</span></h6>			<div class="textwidget"><a href="https://www.lionpublishers.com/"><img src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/uploads/2016/02/lion_memberbadge_horiz.300.jpg" alt="Proud Member of Lion Publishers"/></a></div></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols mh-footer-area mh-footer-4">
<div id="search-3" class="mh-footer-widget widget_search"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Search This Site</span></h6><form role="search" method="get" class="search-form" action="https://www.70westsentinel.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /> </form></div><div id="archives-3" class="mh-footer-widget widget_archive"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Browse Archives</span></h6> <label class="screen-reader-text" for="archives-dropdown-3">Browse Archives</label> <select id="archives-dropdown-3" name="archive-dropdown"> <option value="">Select Month</option> <option value='https://www.70westsentinel.com/2020/03/'> March 2020 </option> <option value='https://www.70westsentinel.com/2020/02/'> February 2020 </option> <option value='https://www.70westsentinel.com/2020/01/'> January 2020 </option> <option value='https://www.70westsentinel.com/2019/12/'> December 2019 </option> <option value='https://www.70westsentinel.com/2019/11/'> November 2019 </option> <option value='https://www.70westsentinel.com/2019/10/'> October 2019 </option> <option value='https://www.70westsentinel.com/2019/09/'> September 2019 </option> <option value='https://www.70westsentinel.com/2019/08/'> August 2019 </option> <option value='https://www.70westsentinel.com/2019/07/'> July 2019 </option> <option value='https://www.70westsentinel.com/2019/06/'> June 2019 </option> <option value='https://www.70westsentinel.com/2019/05/'> May 2019 </option> <option value='https://www.70westsentinel.com/2019/04/'> April 2019 </option> <option value='https://www.70westsentinel.com/2019/03/'> March 2019 </option> <option value='https://www.70westsentinel.com/2019/02/'> February 2019 </option> <option value='https://www.70westsentinel.com/2019/01/'> January 2019 </option> <option value='https://www.70westsentinel.com/2018/12/'> December 2018 </option> <option value='https://www.70westsentinel.com/2018/11/'> November 2018 </option> <option value='https://www.70westsentinel.com/2018/10/'> October 2018 </option> <option value='https://www.70westsentinel.com/2018/09/'> September 2018 </option> <option value='https://www.70westsentinel.com/2018/08/'> August 2018 </option> <option value='https://www.70westsentinel.com/2018/07/'> July 2018 </option> <option value='https://www.70westsentinel.com/2018/06/'> June 2018 </option> <option value='https://www.70westsentinel.com/2018/05/'> May 2018 </option> <option value='https://www.70westsentinel.com/2018/04/'> April 2018 </option> <option value='https://www.70westsentinel.com/2018/03/'> March 2018 </option> <option value='https://www.70westsentinel.com/2018/02/'> February 2018 </option> <option value='https://www.70westsentinel.com/2018/01/'> January 2018 </option> <option value='https://www.70westsentinel.com/2017/12/'> December 2017 </option> <option value='https://www.70westsentinel.com/2017/11/'> November 2017 </option> <option value='https://www.70westsentinel.com/2017/10/'> October 2017 </option> <option value='https://www.70westsentinel.com/2017/09/'> September 2017 </option> <option value='https://www.70westsentinel.com/2017/08/'> August 2017 </option> <option value='https://www.70westsentinel.com/2017/07/'> July 2017 </option> <option value='https://www.70westsentinel.com/2017/06/'> June 2017 </option> <option value='https://www.70westsentinel.com/2017/05/'> May 2017 </option> <option value='https://www.70westsentinel.com/2017/04/'> April 2017 </option> <option value='https://www.70westsentinel.com/2017/03/'> March 2017 </option> <option value='https://www.70westsentinel.com/2017/02/'> February 2017 </option> <option value='https://www.70westsentinel.com/2017/01/'> January 2017 </option> <option value='https://www.70westsentinel.com/2016/12/'> December 2016 </option> <option value='https://www.70westsentinel.com/2016/11/'> November 2016 </option> <option value='https://www.70westsentinel.com/2016/10/'> October 2016 </option> <option value='https://www.70westsentinel.com/2016/09/'> September 2016 </option> <option value='https://www.70westsentinel.com/2016/08/'> August 2016 </option> <option value='https://www.70westsentinel.com/2016/07/'> July 2016 </option> <option value='https://www.70westsentinel.com/2016/06/'> June 2016 </option> <option value='https://www.70westsentinel.com/2016/05/'> May 2016 </option> <option value='https://www.70westsentinel.com/2016/04/'> April 2016 </option> <option value='https://www.70westsentinel.com/2016/03/'> March 2016 </option> <option value='https://www.70westsentinel.com/2016/02/'> February 2016 </option> <option value='https://www.70westsentinel.com/2016/01/'> January 2016 </option> <option value='https://www.70westsentinel.com/2015/12/'> December 2015 </option> <option value='https://www.70westsentinel.com/2015/11/'> November 2015 </option> <option value='https://www.70westsentinel.com/2015/10/'> October 2015 </option> <option value='https://www.70westsentinel.com/2015/09/'> September 2015 </option> <option value='https://www.70westsentinel.com/2015/08/'> August 2015 </option> <option value='https://www.70westsentinel.com/2015/07/'> July 2015 </option> <option value='https://www.70westsentinel.com/2015/06/'> June 2015 </option> <option value='https://www.70westsentinel.com/2015/05/'> May 2015 </option> <option value='https://www.70westsentinel.com/2015/04/'> April 2015 </option> <option value='https://www.70westsentinel.com/2015/03/'> March 2015 </option> <option value='https://www.70westsentinel.com/2015/02/'> February 2015 </option> <option value='https://www.70westsentinel.com/2015/01/'> January 2015 </option> <option value='https://www.70westsentinel.com/2014/12/'> December 2014 </option> <option value='https://www.70westsentinel.com/2014/11/'> November 2014 </option> <option value='https://www.70westsentinel.com/2014/10/'> October 2014 </option> </select></div></div></div></footer>
<div class="mh-footer-nav-mobile"></div><nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-legal-menu-container"><ul id="menu-legal-menu" class="menu"><li id="menu-item-10230" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10230"><a href="https://www.70westsentinel.com/terms-of-service/">Terms of Service</a></li> <li id="menu-item-10229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10229"><a href="https://www.70westsentinel.com/privacy-policy/">Privacy Policy</a></li> <li id="menu-item-121051" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-121051"><a href="https://www.70westsentinel.com/accessibility/">Accessibility</a></li> </ul></div></div></nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix"> <p class="mh-copyright"> Copyright © 2017 70 West Sentinel. All rights reserved. </p></div></div></div><script>let cust_login=document.getElementById("loginform");
if(cust_login!==null){
var recaptcha_script=document.createElement('script');
recaptcha_script.setAttribute('src','https://www.google.com/recaptcha/api.js');
document.head.appendChild(recaptcha_script);
}</script>
<link rel="stylesheet" type="text/css" href="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/d3t49q4z/1g9r.css" media="all"/>
<script src='https://www.google.com/recaptcha/api.js?ver=6738280854131099815cb4fded6ee62d'></script>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='mh-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all'/>
</noscript>
<script>var ai_front={"wp_ai":"5.3.2+2.5.1","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};</script>
<script>var _userway_config={
account: 'c9k51VI8Jy'
};</script>
<script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script>
<script>var pfHeaderImgUrl='';
var pfHeaderTagline='';
var pfdisableClickToDel='1';
var pfImagesSize='full-size';
var pfImageDisplayStyle='left';
var pfEncodeImages='0';
var pfDisableEmail='1';
var pfDisablePDF='0';
var pfDisablePrint='0';
var pfCustomCSS='';
var pfPlatform='Wordpress';</script>
<script>var TribeMiniCalendar={"ajaxurl":"https:\/\/www.70westsentinel.com\/scoop\/wp-admin\/admin-ajax.php"};</script>
<script>var tribe_js_config={"permalink_settings":"\/%postname%\/","events_post_type":"tribe_events","events_base":"https:\/\/www.70westsentinel.com\/events\/","update_urls":{"shortcode":{"list":true,"month":true,"day":true}},"debug":""};</script>
<script>var TribeCalendar={"ajaxurl":"https:\/\/www.70westsentinel.com\/scoop\/wp-admin\/admin-ajax.php","post_type":"tribe_events"};</script>
<script src='//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/35qlfeg/1g97.js'></script>
<script>(function(a){if("function"===typeof define&&define.amd){define(a);var b=!0}"object"===typeof exports&&(module.exports=a(),b=!0);if(!b){var f=window.Cookies,d=window.Cookies=a();d.noConflict=function(){window.Cookies=f;return d}}})(function(){function a(){for(var a=0,b={};a<arguments.length;a++){var e=arguments[a],c;for(c in e)b[c]=e[c]}return b}function b(f){function d(){}function e(b,c,e){if("undefined"!==typeof document){e=a({path:"/"},d.defaults,e);"number"===typeof e.expires&&(e.expires=new Date(1*
new Date+864E5*e.expires));e.expires=e.expires?e.expires.toUTCString():"";try{var g=JSON.stringify(c);/^[\{\[]/.test(g)&&(c=g)}catch(n){}c=f.write?f.write(c,b):encodeURIComponent(String(c)).replace(/%(23|24|26|2B|3A|3C|3E|3D|2F|3F|40|5B|5D|5E|60|7B|7D|7C)/g,decodeURIComponent);b=encodeURIComponent(String(b)).replace(/%(23|24|26|2B|5E|60|7C)/g,decodeURIComponent).replace(/[\(\)]/g,escape);g="";for(var k in e)e[k]&&(g+="; "+k,!0!==e[k]&&(g+="="+e[k].split(";")[0]));return document.cookie=b+"="+c+g}}
function c(a,b){if("undefined"!==typeof document){for(var c={},d=document.cookie?document.cookie.split("; "):[],e=0;e<d.length;e++){var g=d[e].split("="),h=g.slice(1).join("=");b||'"'!==h.charAt(0)||(h=h.slice(1,-1));try{var l=g[0].replace(/(%[0-9A-Z]{2})+/g,decodeURIComponent);h=(f.read||f)(h,l)||h.replace(/(%[0-9A-Z]{2})+/g,decodeURIComponent);if(b)try{h=JSON.parse(h)}catch(m){}c[l]=h;if(a===l)break}catch(m){}}return a?c[a]:c}}d.set=e;d.get=function(a){return c(a,!1)};d.getJSON=function(a){return c(a,
!0)};d.remove=function(b,c){e(b,"",a(c,{expires:-1}))};d.defaults={};d.withConverter=b;return d}return b(function(){})});AiCookies=Cookies.noConflict();
function ai_check_block(a){var b=AiCookies.getJSON("aiBLOCKS");ai_debug_cookie_status="";null==b&&(b={});"undefined"!==typeof ai_delay_showing_pageviews&&(b.hasOwnProperty(a)||(b[a]={}),b[a].hasOwnProperty("d")||(b[a].d=ai_delay_showing_pageviews));if(b.hasOwnProperty(a))for(var f in b[a]){if("x"==f){var d=document.querySelectorAll('span[data-ai-block="'+a+'"]')[0].dataset.aiHash,e="";b[a].hasOwnProperty("h")&&(e=b[a].h);var c=new Date;c=b[a][f]-Math.round(c.getTime()/1E3);if(0<c&&e==d)return ai_debug_cookie_status=
a="closed for "+c+" s="+Math.round(1E4*c/3600/24)/1E4+" days",!1;ai_set_cookie(a,"x","");b[a].hasOwnProperty("i")||b[a].hasOwnProperty("c")||ai_set_cookie(a,"h","")}else if("d"==f){if(0!=b[a][f])return ai_debug_cookie_status=a="delayed for "+b[a][f]+" pageviews",!1}else if("i"==f){d=document.querySelectorAll('span[data-ai-block="'+a+'"]')[0].dataset.aiHash;e="";b[a].hasOwnProperty("h")&&(e=b[a].h);if(0==b[a][f]&&e==d)return ai_debug_cookie_status=a="max impressions reached",!1;if(0>b[a][f]&&e==d){c=new Date;c=-b[a][f]-Math.round(c.getTime()/1E3);if(0<c)return ai_debug_cookie_status=a="max imp. reached ("+Math.round(1E4*c/24/3600)/1E4+" days="+c+" s)",!1;ai_set_cookie(a,"i","");b[a].hasOwnProperty("c")||b[a].hasOwnProperty("x")||ai_set_cookie(a,"h","")}}if("ipt"==f&&0==b[a][f]&&(c=new Date,d=Math.round(c.getTime()/1E3),c=b[a].it-d,0<c))return ai_debug_cookie_status=a="max imp. per time reached ("+Math.round(1E4*c/24/3600)/1E4+" days="+c+" s)",!1;if("c"==f){d=document.querySelectorAll('span[data-ai-block="'+
a+'"]')[0].dataset.aiHash;e="";b[a].hasOwnProperty("h")&&(e=b[a].h);if(0==b[a][f]&&e==d)return ai_debug_cookie_status=a="max clicks reached",!1;if(0>b[a][f]&&e==d){c=new Date;c=-b[a][f]-Math.round(c.getTime()/1E3);if(0<c)return ai_debug_cookie_status=a="max clicks reached ("+Math.round(1E4*c/24/3600)/1E4+" days="+c+" s)",!1;ai_set_cookie(a,"c","");b[a].hasOwnProperty("i")||b[a].hasOwnProperty("x")||ai_set_cookie(a,"h","")}}if("cpt"==f&&0==b[a][f]&&(c=new Date,d=Math.round(c.getTime()/1E3),c=b[a].ct-
d,0<c))return ai_debug_cookie_status=a="max clicks per time reached ("+Math.round(1E4*c/24/3600)/1E4+" days="+c+" s)",!1}ai_debug_cookie_status="OK";return!0}function ai_load_cookie(){var a=AiCookies.getJSON("aiBLOCKS");null==a&&(a={});return a}function ai_get_cookie(a,b){var f="",d=ai_load_cookie();d.hasOwnProperty(a)&&d[a].hasOwnProperty(b)&&(f=d[a][b]);return f}
function ai_set_cookie(a,b,f){var d=ai_load_cookie();if(""===f){if(d.hasOwnProperty(a)){delete d[a][b];a:{b=d[a];for(e in b)if(b.hasOwnProperty(e)){var e=!1;break a}e=!0}e&&delete d[a]}}else d.hasOwnProperty(a)||(d[a]={}),d[a][b]=f;0===Object.keys(d).length&&d.constructor===Object?AiCookies.remove("aiBLOCKS"):AiCookies.set("aiBLOCKS",d,{expires:365,path:"/"});return d}
function ai_get_cookie_text(a){var b=AiCookies.getJSON("aiBLOCKS");null==b&&(b={});return b.hasOwnProperty(a)?JSON.stringify(b[a]).replace(/"/g,"").replace("{","").replace("}",""):""};</script>
<script src='//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/2b4nludo/1g97.js'></script>
<script src='//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/themes/mh-magazine-child/js/customjq.js?ver=6738280854131099815cb4fded6ee62d'></script>
<script src='//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/lw0mb7kd/1g97.js'></script>
<!--[if lt IE 9]><script src="//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/l9ajl6i0/1g97.js"></script><![endif]-->
<script>(function(){
var dropdown=document.getElementById("archives-dropdown-3");
function onSelectChange(){
if(dropdown.options[ dropdown.selectedIndex ].value!==''){
document.location.href=this.options[ this.selectedIndex ].value;
}}
dropdown.onchange=onSelectChange;
})();</script>
<script>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</script>
<script src="https://cdn.userway.org/widget.js"></script>
<script>(function(body){
'use strict';
body.className=body.className.replace(/\btribe-no-js\b/, 'tribe-js');
})(document.body);</script>
<script defer async src='https://cdn.printfriendly.com/printfriendly.js'></script>
<script defer src='//cdn2-5vk2dauxl7hlyrpvalp.netdna-ssl.com/scoop/wp-content/cache/wpfc-minified/2f9kqjo5/1jkq.js'></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
</body>
</html><!-- WP Fastest Cache file was created in 1.7323689460754 seconds, on 27-03-20 17:21:56 -->